MASM32 SDK Description, downloads and other helpful links New Forum Link
masmforum WebSite

cant run my MASM program

Started by xdc, April 30, 2012, 04:15:59 AM

Previous topic - Next topic


well just to be sure, windows 7 32-bit will allow me to run these 16 bit programs, etc? (sorry)
because i've tried virtual XP and it gives me the same error.

i was thinking dual boot: windows 7 32bit, and Ubuntu 64 bit. All the other computers around here are also 64-bit

also what are the thoughts on inline assembly (vc++)?
Is it a good way to learn assembly? I want to write 100% assembly code, doing it through
vc++ seems to do some of the work for me


DOS is dead and support dropped from newer OS's (VISTA and above)  I use DFend-Reloaded as a front end to DOSBox this way I can run any 16bit code I write though some code doesn't work correctly and in that case, I fire up a XP virtual machine to run it.
~Rob (Gunner)
- IE Zone Editor
- Gunners File Type Editor



Windows XP Mode on Windows 7 64-bit will run 16-bit programs. I know it will because I have done it.

It sounds like that debugger messed up your system.

As far as inline assembly, I wouldn't recommend it.

You could use ml.exe, link16.exe and OllyDbg.  Honestly, I have no idea which debuggers work with 16- bit code because it has been such a long time since I debugged any 16-bit code.

Do yourself a big favor and start with 32-bit code.


Quote from: GregL on May 01, 2012, 11:43:25 PM

Windows XP Mode on Windows 7 64-bit will run 16-bit programs. I know it will because I have done it.

ok, please forgive me, im a newbie

source code, no errors (32 bit?) (using vc++ 2010 ml and link.exe )

run through virtual xp:



I edited my post above. I don't know what to say, I was able to run 16-bit programs in Window XP Mode on my Windows 7 64-bit system.



That's 32-bit code. I'm confused about what the problem is. It really looks like that debugger messed up your system.


ok, im sure thats the problem too.

i guess im gonna have to reformat the harddrive.
as i did a fresh install of windows(to see if it would fix), but didn't erase the data
(it was moved to a windows.old)


if you do some research (via google)...
i saw an article someplace that described how to completely remove that debugger
apparently, it is problematic in uninstall


sorry, i cant find anything. all i get is the sites asking me to install their software to uninstall etc ill keep looking


I have reformated my harddrive(deleted files/partitions) ( through windows 7 cd).
Fresh install of windows 7 64-bit, downloaded all updates, visual c++ 2010 express, masm32, oracle virtualbox, notepad++

tried to run a 32 bit masm program, still didn't work. tried it through virtual xp mode, still got the same errors from before the reformat.
tried running it with both 16 - 32 bit programs on both windows 7/virtual xp, I think i even tried 64 bit but still got the same error, etc
I got some error from before about virtualization tech on cpu not being enabled before installing virtual xp, even though virtualbox installed fine, and
when i went to BIOS virtual etc was already enabled, so i installed a patch for virtual xp to make it work 'without it'.

So either I didn't completely wipe my harddrive,
something is wrong in BIOS settings,
im installing something else that could be messing it up,
or masm32 wasnt meant to work on my computer using windows 7 64 bit with virtual xp, etc

I can't program in assembly without masm, etc every documentation i've been reading is using masm, etc 'art of assembly'...

anyway, im thinking about completely wiping the harddrive, and installing Ubuntu 64, or ubuntu server ( been wanting to try out server OS)
I'm getting problems installing ubuntu after the reformat, it wont load through cd, or installing in windows, etc ubuntu server only seems to load through CD
Is there a program I can use to program using masm syntax etc for Ubuntu?

Do you have any suggestions as to what I can do. I've actually tried this on a laptop of mine that has windows 7 64 bit, installed virtual xp, masm32, etc still got the same errors.
Gonna have to try it on another computer of mine to see if its not just my pc(edit just tried on another computer, windows 7 64bit, virtual xp, same errors)

Gonna have to try installing windows xp professional 32bit as another boot option