Hi,
Is it possible to change the default control names assigned to controls when they are created by the dialog editor? For example, could I make it so that rather than being called "IDC_BTN1", a new button would be called "BTN_1" by default? That way changing the name to "BTN_ABOUT" or "BTN_EXIT" would be even easier and the final constant name would be shorter than "IDC_BTN_ABOUT".
The reason I'm asking is that it seems to me the name "IDC_BTN1" is only used by RadASM in the resource scripts anyway, and that if I want to have a constant identifier for the control in code, I have to define a constant for it in code anyway. So my thought is why not just make a default name that is useful and succinct in code since the resource scripts are managed by RadASM automatically?
Thanks in advance.
Hi Artimus (and Ketilo :) )
this is a kind of "to each his own" thing but how about if we can have a convention for the control names:
IDB_??? for buttons
IDCB_??? for comboboxes
IDLB_??? for listboxes
IDLV_??? for listview
.
.
.
etc...
I have found the IDB_??? a bit simpler than the IDC_BTN??? thing :)
Hi
Here is a very simple addin that lets you modify default names and captions.
KetilO
[attachment deleted by admin]
Thank you very much.